Veel

Kas faili ESRI.ArcGIS.ADF.Local ei õnnestunud laadida?

Kas faili ESRI.ArcGIS.ADF.Local ei õnnestunud laadida?


Proovisin just registreerida oma laienduse ArcGIS 10 jaoks 10.1 beetaversioonis ja see ebaõnnestus, kui proovisin dll-i registreerida: "Faili või assamblee 'ESRI.ArcGIS.ADF.Local' Version = 10.0.0.0 ei õnnestunud laadida."

Kas pean selle töötamiseks uuesti kompileerima 10,1 dll-i vastu? 9.x versiooni puhul pidin ma vaid need kompileerima baastaseme (9.2) vastu ja see toimis ka versioonis 9.3.


Poliitikafaile, mis suunavad rakendusi ümber ESRI komplektide uuematesse versioonidesse, ei levitata ArcGIS-iga enam alates 10.0.

Ma ei saa spetsiaalselt 10.1 beetaversiooni kommenteerida, kuna mul pole seda installitud, kuid olen aru saanud, et ESRI ei levita neid poliitikafaile enam nii, et arendajad on sunnitud uuel versioonil oma kohandusi testima (ja uuesti kompileerima). Võib-olla sisaldab lõplik 10.1 poliitikafaile, mis võimaldaksid 10.0-le assamblee viiteid 10.1-le suunata.

Kui arendate eraldiseisvat rakendust, saate selle konfiguratsioonifailis määrata ise ümbersuunamised. ArcMapi jaoks peate lisama ümbersuunamise konfiguratsiooni kaadrisse ArcMap.exe.config, mis asub lisaks ArcMap.exe-le.

Pange tähele ka levinud eksiarvamust: tundub, et paljud inimesed usuvad, et Visual Studios montaaživiite lülitil "Spetsiifiline versioon" on mis tahes käitamisefekt. See mõjutab ainult VS-i, mitte sellest tulenevat kompileeritud käitumist.


Vaata videot: Importing AutoCAD Drawing to ArcGIS as a Shapefile very Easy Method